CVE-2018-14041

NameCVE-2018-14041
DescriptionIn Bootstrap before 4.1.2, XSS is possible in the data-target property of scrollspy.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs907414

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
twitter-bootstrap (PTS)jessie2.0.2+dfsg-5fixed
sid, stretch2.0.2+dfsg-10fixed
twitter-bootstrap3 (PTS)jessie3.2.0+dfsg-1fixed
jessie (security)3.2.0+dfsg-1+deb7u1fixed
buster, sid, stretch3.3.7+dfsg-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
twitter-bootstrapsource(unstable)(not affected)
twitter-bootstrap3source(unstable)(unfixed)low907414
twitter-bootstrap3sourcejessie(not affected)

Notes

- twitter-bootstrap <not-affected> (Vulnerable code not present)
[stretch] - twitter-bootstrap3 <no-dsa> (Minor issue)
[jessie] - twitter-bootstrap3 <not-affected> (Vulnerable code not present)
https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2/
https://github.com/twbs/bootstrap/issues/26423
https://github.com/twbs/bootstrap/issues/26627
https://github.com/twbs/bootstrap/pull/26630
https://github.com/twbs/bootstrap/pull/26630/commits/3229efc0811df29765c1d0a949c85362378b0628

Search for package or bug name: Reporting problems