CVE-2018-15470

NameCVE-2018-15470
DescriptionAn issue was discovered in Xen through 4.11.x. The logic in oxenstored for handling writes depended on the order of evaluation of expressions making up a tuple. As indicated in section 7.7.3 "Operations on data structures" of the OCaml manual, the order of evaluation of subexpressions is not specified. In practice, different implementations behave differently. Thus, oxenstored may not enforce the configured quota-maxentity. This allows a malicious or buggy guest to write as many xenstore entries as it wishes, causing unbounded memory usage in oxenstored. This can lead to a system-wide DoS.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1577-1, DSA-4274-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts4-0+deb8u1fixed
stretch (security), stretch4.8.4+xsa273+shim4.10.1+xsa273-1+deb9u10fixed
buster, sid4.11.1~pre.20180911.5acdd26fdc+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.11.1~pre.20180911.5acdd26fdc+dfsg-2unimportant
xensourcejessie4.4.4lts4-0+deb8u1mediumDLA-1577-1
xensourcestretch4.8.4+xsa273+shim4.10.1+xsa273-1+deb9u10mediumDSA-4274-1

Notes

https://xenbits.xen.org/xsa/advisory-272.html

Search for package or bug name: Reporting problems