CVE-2018-16862

NameCVE-2018-16862
DescriptionA security flaw was found in the Linux kernel in a way that the cleancache subsystem clears an inode after the final file truncation (removal). The new file created with the same inode may contain leftover pages from cleancache and the old file data instead of the new one.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1715-1, DLA-1731-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.68-1fixed
stretch4.9.168-1fixed
stretch (security)4.9.168-1+deb9u2fixed
buster, sid4.19.37-3fixed
linux-4.9 (PTS)jessie (security)4.9.168-1+deb9u2~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.19.9-1low
linuxsourcejessie3.16.64-1lowDLA-1731-1
linuxsourcestretch4.9.144-1low
linux-4.9sourcejessie4.9.144-3.1~deb8u1lowDLA-1715-1

Notes

https://lore.kernel.org/patchwork/patch/1011367/
https://bugzilla.redhat.com/show_bug.cgi?id=1649017
Fixed by: https://git.kernel.org/linus/6ff38bd40230af35e446239396e5fc8ebd6a5248

Search for package or bug name: Reporting problems