CVE-2018-18690

NameCVE-2018-18690
DescriptionIn the Linux kernel before 4.17, a local attacker able to set attributes on an xfs filesystem could make this filesystem non-operational until the next mount by triggering an unchecked error condition during an xfs attribute change, because xfs_attr_shortform_addname in fs/xfs/libxfs/xfs_attr.c mishandles ATTR_REPLACE operations with conversion of an attr from short to long form.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.59-1vulnerable
stretch4.9.130-2vulnerable
stretch (security)4.9.110-3+deb9u6vulnerable
buster, sid4.18.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.17.3-1

Notes

https://bugzilla.kernel.org/show_bug.cgi?id=199119
https://bugzilla.suse.com/show_bug.cgi?id=1105025
https://git.kernel.org/linus/7b38460dc8e4eafba06c78f8e37099d3b34d473c

Search for package or bug name: Reporting problems