CVE-2018-19198

NameCVE-2018-19198
DescriptionAn issue was discovered in uriparser before 0.9.0. UriQuery.c allows an out-of-bounds write via a uriComposeQuery* or uriComposeQueryEx* function because the '&' character is mishandled in certain contexts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1581-1
NVD severityhigh (attack range: remote)
Debian Bugs913817

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
uriparser (PTS)jessie0.8.0.1-2vulnerable
jessie (security)0.8.0.1-2+deb8u2fixed
stretch0.8.4-1+deb9u1fixed
buster, sid0.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
uriparsersource(unstable)0.9.0-1high913817
uriparsersourcejessie0.8.0.1-2+deb8u1highDLA-1581-1
uriparsersourcestretch0.8.4-1+deb9u1high

Notes

https://github.com/uriparser/uriparser/commit/864f5d4c127def386dd5cc926ad96934b297f04e

Search for package or bug name: Reporting problems