Information on source package uriparser

Available versions

ReleaseVersion
stretch0.8.4-1+deb9u1
stretch (security)0.8.4-1+deb9u4
buster0.9.1-1+deb10u1
bullseye0.9.4+dfsg-1+deb11u1
bookworm0.9.6+dfsg-1
sid0.9.6+dfsg-1

Resolved issues

BugDescription
CVE-2021-46142An issue was discovered in uriparser before 0.9.6. It performs invalid ...
CVE-2021-46141An issue was discovered in uriparser before 0.9.6. It performs invalid ...
CVE-2018-20721URI_FUNC() in UriParse.c in uriparser before 0.9.1 has an out-of-bound ...
CVE-2018-19200An issue was discovered in uriparser before 0.9.0. UriCommon.c allows ...
CVE-2018-19199An issue was discovered in uriparser before 0.9.0. UriQuery.c allows a ...
CVE-2018-19198An issue was discovered in uriparser before 0.9.0. UriQuery.c allows a ...

Security announcements

DSA / DLADescription
DSA-5063-1uriparser - security update
DLA-2883-2uriparser - regression update
DLA-2883-1uriparser - security update
DLA-2834-1uriparser - security update
DLA-1682-1uriparser - security update
DLA-1581-1uriparser - security update

Search for package or bug name: Reporting problems