CVE-2018-19296

NameCVE-2018-19296
DescriptionPHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1591-1, DSA-4351-1
Debian Bugs913912

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libphp-phpmailer (PTS)jessie5.2.9+dfsg-2+deb8u3vulnerable
jessie (security)5.2.9+dfsg-2+deb8u4fixed
stretch5.2.14+dfsg-2.3vulnerable
stretch (security)5.2.14+dfsg-2.3+deb9u1fixed
buster, sid5.2.14+dfsg-2.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libphp-phpmailersource(unstable)5.2.14+dfsg-2.4913912
libphp-phpmailersourcejessie5.2.9+dfsg-2+deb8u4DLA-1591-1
libphp-phpmailersourcestretch5.2.14+dfsg-2.3+deb9u1DSA-4351-1

Notes

https://github.com/PHPMailer/PHPMailer/commit/f1231a9771505f4f34da060390d82eadb8448271

Search for package or bug name: Reporting problems