CVE-2018-19396

NameCVE-2018-19396
Descriptionext/standard/var_unserializer.c in PHP 5.x through 7.1.24 allows attackers to cause a denial of service (application crash) via an unserialize call for the com, dotnet, or variant class.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie5.6.33+dfsg-0+deb8u1fixed
jessie (security)5.6.40+dfsg-0+deb8u6fixed
php7.0 (PTS)stretch7.0.33-0+deb9u3fixed
stretch (security)7.0.33-0+deb9u5fixed
php7.3 (PTS)buster7.3.4-2fixed
buster (security)7.3.9-1~deb10u1fixed
bullseye, sid7.3.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(not affected)
php7.0source(unstable)(not affected)
php7.1source(unstable)(not affected)
php7.2source(unstable)(not affected)
php7.3source(unstable)(not affected)

Notes

- php7.3 <not-affected> (Windows-specific)
- php7.2 <not-affected> (Windows-specific)
- php7.1 <not-affected> (Windows-specific)
- php7.0 <not-affected> (Windows-specific)
- php5 <not-affected> (Windows-specific)
https://bugs.php.net/bug.php?id=77177

Search for package or bug name: Reporting problems