CVE-2018-19491

NameCVE-2018-19491
DescriptionAn issue was discovered in post.trm in Gnuplot 5.2.5. This issue allows an attacker to conduct a buffer overflow with an arbitrary amount of data in the PS_options function. This flaw is caused by a missing size check of an argument passed to the "set font" function. This issue occurs when the Gnuplot postscript terminal is used as a backend.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1595-1, DLA-1597-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnuplot (PTS)stretch5.0.5+dfsg1-6+deb9u1vulnerable
buster5.2.6+dfsg1-1+deb10u1vulnerable
bullseye, sid5.4.1+dfsg1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnuplotsourcejessie4.6.6-2+deb8u1DLA-1597-1
gnuplotsource(unstable)(unfixed)unimportant
gnuplot5sourcejessie5.0.0~rc+dfsg2-1+deb8u1DLA-1595-1
gnuplot5source(unstable)(unfixed)unimportant

Notes

https://sourceforge.net/p/gnuplot/bugs/2094/
https://sourceforge.net/p/gnuplot/gnuplot-main/ci/d5020716834582b20a5e12cdd49f39ee4f9dd949/
No security impact, gnuplot can execute arbitrary commands and need to come from a trusted source,
see README.Debian.security (added in 5.2.6)

Search for package or bug name: Reporting problems