CVE-2018-20196

NameCVE-2018-20196
DescriptionThere is a stack-based buffer overflow in the third instance of the calculate_gain function in libfaad/sbr_hfadj.c in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. A crafted input will lead to a denial of service or possibly unspecified other impact because the S_M array is mishandled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1899-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
faad2 (PTS)stretch2.8.0~cvs20161113-1+deb9u2vulnerable
stretch (security)2.8.0~cvs20161113-1+deb9u3vulnerable
buster2.8.8-3vulnerable
bullseye2.10.0-1fixed
bookworm, sid2.10.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
faad2sourcejessie2.7-8+deb8u3DLA-1899-1
faad2source(unstable)2.8.8-3.1low

Notes

[buster] - faad2 <no-dsa> (Minor issue)
[stretch] - faad2 <no-dsa> (Minor issue)
https://github.com/knik0/faad2/issues/19
https://github.com/knik0/faad2/commit/6aeeaa1af0caf986daf22852a97f7c13c5edd879

Search for package or bug name: Reporting problems