CVE-2018-20677

NameCVE-2018-20677
DescriptionIn Bootstrap before 3.4.0, XSS is possible in the affix configuration target property.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
twitter-bootstrap (PTS)jessie2.0.2+dfsg-5vulnerable
sid, stretch2.0.2+dfsg-10vulnerable
twitter-bootstrap3 (PTS)jessie3.2.0+dfsg-1vulnerable
jessie (security)3.2.0+dfsg-1+deb7u1vulnerable
stretch3.3.7+dfsg-2+deb9u2fixed
buster, sid3.4.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
twitter-bootstrapsource(unstable)(unfixed)medium
twitter-bootstrap3source(unstable)3.4.0+dfsg-1medium
twitter-bootstrap3sourcestretch3.3.7+dfsg-2+deb9u1medium

Notes

[stretch] - twitter-bootstrap <no-dsa> (Minor issue)
[jessie] - twitter-bootstrap <no-dsa> (Minor issue)
[jessie] - twitter-bootstrap3 <no-dsa> (Minor issue)
https://github.com/twbs/bootstrap/issues/27045
https://github.com/twbs/bootstrap/issues/27915#issuecomment-452140906
https://github.com/twbs/bootstrap/issues/27915#issuecomment-452196628
https://github.com/twbs/bootstrap/pull/27047
https://github.com/twbs/bootstrap/commit/2a5ba23ce8f041f3548317acc992ed8a736b609d (v3.4.0)

Search for package or bug name: Reporting problems