CVE-2018-20743

NameCVE-2018-20743
Descriptionmurmur in Mumble through 1.2.19 before 2018-08-31 mishandles multiple concurrent requests that are persisted in the database, which allows remote attackers to cause a denial of service (daemon hang or crash) via a message flood.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1661-1, DSA-4402-1
NVD severitymedium (attack range: remote)
Debian Bugs919249

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mumble (PTS)jessie1.2.8-2vulnerable
jessie (security)1.2.8-2+deb8u1fixed
stretch (security), stretch1.2.18-1+deb9u1fixed
bullseye, sid, buster1.3.0~git20190125.440b173+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mumblesource(unstable)1.3.0~git20190114.9fcc588+dfsg-1medium919249
mumblesourcejessie1.2.8-2+deb8u1mediumDLA-1661-1
mumblesourcestretch1.2.18-1+deb9u1mediumDSA-4402-1

Notes

https://github.com/mumble-voip/mumble/issues/3505
https://github.com/mumble-voip/mumble/pull/3510
https://github.com/mumble-voip/mumble/pull/3512

Search for package or bug name: Reporting problems