CVE-2018-5147

NameCVE-2018-5147
DescriptionThe libtremor library has the same flaw as CVE-2018-5146. This library is used by Firefox in place of libvorbis on Android and ARM platforms. This vulnerability affects Firefox ESR < 52.7.2 and Firefox < 59.0.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1312-1, DLA-1319-1, DSA-4141-1, DSA-4143-1
NVD severityhigh (attack range: remote)
Debian Bugs893132

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid68.0-3fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)60.7.1esr-1~deb8u1fixed
stretch60.6.1esr-1~deb9u1fixed
stretch (security)60.8.0esr-1~deb9u1fixed
buster60.7.2esr-1fixed
buster (security)60.8.0esr-1~deb10u1fixed
bullseye, sid60.8.0esr-1fixed
libvorbisidec (PTS)jessie (security), jessie1.0.2+svn18153-1~deb8u2fixed
stretch (security), stretch1.0.2+svn18153-1+deb9u1fixed
bullseye, sid, buster1.2.1+git20180316-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)59.0.1-1high
firefox-esrsource(unstable)52.7.2esr-1high
firefox-esrsourcejessie52.7.2esr-1~deb8u1highDSA-4143-1
firefox-esrsourcestretch52.7.2esr-1~deb9u1highDSA-4143-1
firefox-esrsourcewheezy52.7.2esr-1~deb7u1highDLA-1319-1
libvorbisidecsource(unstable)1.2.1+git20180316-1high893132
libvorbisidecsourcejessie1.0.2+svn18153-1~deb8u2highDSA-4141-1
libvorbisidecsourcestretch1.0.2+svn18153-1+deb9u1highDSA-4141-1
libvorbisidecsourcewheezy1.0.2+svn18153-0.2+deb7u1highDLA-1312-1

Notes

https://git.xiph.org/?p=tremor.git;a=commit;h=562307a4a7082e24553f3d2c55dab397a17c4b4f
https://www.mozilla.org/en-US/security/advisories/mfsa2018-08/

Search for package or bug name: Reporting problems