CVE-2018-5391

NameCVE-2018-5391
DescriptionThe Linux kernel, versions 3.9+, is vulnerable to a denial of service attack with low rates of specially modified packets targeting IP fragment re-assembly. An attacker may cause a denial of service condition by sending specially crafted IP fragments. Various vulnerabilities in IP fragmentation have been discovered and fixed over the years. The current vulnerability (CVE-2018-5391) became exploitable in the Linux kernel with the increase of the IP fragment reassembly queue size.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1466-1, DLA-1529-1, DSA-4272-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie3.16.56-1+deb8u1vulnerable
jessie (security)3.16.59-1fixed
stretch4.9.130-2fixed
stretch (security)4.9.110-3+deb9u6fixed
buster, sid4.18.20-2fixed
linux-4.9 (PTS)jessie (security)4.9.110-3+deb9u5~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.17.15-1high
linuxsourcejessie3.16.59-1highDLA-1529-1
linuxsourcestretch4.9.110-3+deb9u2highDSA-4272-1
linux-4.9sourcejessie4.9.110-3+deb9u2~deb8u1highDLA-1466-1

Notes

Mitigation: Change the default values of net.ipv4.ipfrag_high_thresh and
net.ipv4.ipfrag_low_thresh back to 256kB and 192 kB (respectively) or
below.

Search for package or bug name: Reporting problems