|Description||The Linux kernel, versions 3.9+, is vulnerable to a denial of service attack with low rates of specially modified packets targeting IP fragment re-assembly. An attacker may cause a denial of service condition by sending specially crafted IP fragments. Various vulnerabilities in IP fragmentation have been discovered and fixed over the years. The current vulnerability (CVE-2018-5391) became exploitable in the Linux kernel with the increase of the IP fragment reassembly queue size.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)|
|References||DLA-1466-1, DLA-1529-1, DLA-1715-1, DSA-4272-1|
Vulnerable and fixed packages
The table below lists information on source packages.
|linux-4.9 (PTS)||jessie (security)||4.9.210-1~deb8u1||fixed|
The information below is based on the following data on fixed versions.
Mitigation: Change the default values of net.ipv4.ipfrag_high_thresh and
net.ipv4.ipfrag_low_thresh back to 256kB and 192 kB (respectively) or