CVE-2018-6871

NameCVE-2018-6871
DescriptionLibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary files via =WEBSERVICE calls in a document, which use the COM.MICROSOFT.WEBSERVICE function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4111-1, DSA-4111-2

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)buster1:6.1.5-3+deb10u7fixed
buster (security)1:6.1.5-3+deb10u11fixed
bullseye1:7.0.4-4+deb11u8fixed
bullseye (security)1:7.0.4-4+deb11u9fixed
bookworm4:7.4.7-1+deb12u1fixed
bookworm (security)4:7.4.7-1+deb12u2fixed
sid, trixie4:24.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesourcewheezy(not affected)
libreofficesourcejessie1:4.3.3-2+deb8u10DSA-4111-2
libreofficesourcestretch1:5.2.7-1+deb9u2DSA-4111-1
libreofficesource(unstable)1:6.0.1-1

Notes

[wheezy] - libreoffice <not-affected> (Vulnerable code not present)
https://github.com/jollheef/libreoffice-remote-arbitrary-file-disclosure

Search for package or bug name: Reporting problems