CVE-2018-7033

NameCVE-2018-7033
DescriptionSchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1367-1
NVD severityhigh (attack range: remote)
Debian Bugs893044

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
slurm-llnl (PTS)jessie14.03.9-5+deb8u2vulnerable
stretch (security), stretch16.05.9-1+deb9u1vulnerable
buster, sid17.11.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
slurm-llnlsource(unstable)17.11.5-1high893044
slurm-llnlsourcewheezy2.3.4-2+deb7u2highDLA-1367-1

Notes

https://bugs.schedmd.com/show_bug.cgi?id=4792 (not yet public)
https://github.com/SchedMD/slurm/commit/db468895240ad6817628d07054fe54e71273b2fe
https://github.com/SchedMD/slurm/commit/2f5e924bf6e018dbcef24bcda9683d6b3662f6d4

Search for package or bug name: Reporting problems