CVE-2018-7584

NameCVE-2018-7584
DescriptionIn PHP through 5.6.33, 7.0.x before 7.0.28, 7.1.x through 7.1.14, and 7.2.x through 7.2.2, there is a stack-based buffer under-read while parsing an HTTP response in the php_stream_url_wrap_http_ex function in ext/standard/http_fopen_wrapper.c. This subsequently results in copying a large string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1326-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)jessie (security), jessie5.6.33+dfsg-0+deb8u1vulnerable
php7.0 (PTS)stretch (security), stretch7.0.27-0+deb9u1vulnerable
sid7.0.29-1fixed
php7.1 (PTS)buster, sid7.1.16-1fixed
php7.2 (PTS)buster, sid7.2.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)high
php5sourcewheezy5.4.45-0+deb7u13highDLA-1326-1
php7.0source(unstable)7.0.28-1high
php7.1source(unstable)7.1.15-1high
php7.2source(unstable)7.2.3-1high

Notes

Fixed in 5.6.34, 7.0.28, 7.1.15, 7.2.3
PHP Bug: https://bugs.php.net/bug.php?id=75981
https://github.com/php/php-src/commit/523f230c831d7b33353203fa34aee4e92ac12bba

Search for package or bug name: Reporting problems