CVE-2019-10130

NameCVE-2019-10130
DescriptionA vulnerability was found in PostgreSQL versions 11.x up to excluding 11.3, 10.x up to excluding 10.8, 9.6.x up to, excluding 9.6.13, 9.5.x up to, excluding 9.5.17. PostgreSQL maintains column statistics for tables. Certain statistics, such as histograms and lists of most common values, contain values taken from the column. PostgreSQL does not evaluate row security policies before consulting those statistics during query planning; an attacker can exploit this to read the most common values of certain columns. Affected columns are those for which the attacker has SELECT privilege and for which, in an ordinary query, row-level security prunes the set of rows visible to the attacker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4439-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster11.4-1fixed
buster (security)11.5-1+deb10u1fixed
bullseye, sid11.5-1fixed
postgresql-9.4 (PTS)jessie9.4.18-0+deb8u1fixed
jessie (security)9.4.24-0+deb8u1fixed
postgresql-9.6 (PTS)stretch9.6.12-0+deb9u1vulnerable
stretch (security)9.6.15-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11source(unstable)11.3-1medium
postgresql-9.4source(unstable)(unfixed)medium
postgresql-9.4sourcejessie(not affected)
postgresql-9.6source(unstable)(unfixed)medium
postgresql-9.6sourcestretch9.6.13-0+deb9u1mediumDSA-4439-1

Notes

[jessie] - postgresql-9.4 <not-affected> (Row security was introduced in 9.5)
https://www.postgresql.org/about/news/1939/

Search for package or bug name: Reporting problems