CVE-2019-12293

NameCVE-2019-12293
DescriptionIn Poppler through 0.76.1, there is a heap-based buffer over-read in JPXStream::init in JPEG2000Stream.cc via data with inconsistent heights or widths.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1815-1, DLA-2287-1
NVD severitymedium
Debian Bugs929423

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)stretch0.48.0-2+deb9u2vulnerable
stretch (security)0.48.0-2+deb9u4fixed
buster0.71.0-5fixed
bullseye, sid20.09.0-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourcejessie0.26.5-2+deb8u10DLA-1815-1
popplersourcestretch0.48.0-2+deb9u3DLA-2287-1
popplersource(unstable)0.71.0-5929423

Notes

https://gitlab.freedesktop.org/poppler/poppler/issues/768
https://gitlab.freedesktop.org/poppler/poppler/commit/89a5367d49b2556a2635dbb6d48d6a6b182a2c6c

Search for package or bug name: Reporting problems