CVE-2019-16255

NameCVE-2019-16255
DescriptionRuby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2007-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jruby (PTS)jessie1.5.6-9vulnerable
jessie (security)1.5.6-9+deb8u1vulnerable
stretch (security), stretch1.7.26-1+deb9u1vulnerable
buster, bullseye, sid9.1.17.0-3vulnerable
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u8fixed
ruby2.3 (PTS)stretch (security), stretch2.3.3-1+deb9u6vulnerable
ruby2.5 (PTS)buster2.5.5-3vulnerable
bullseye, sid2.5.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jrubysource(unstable)(unfixed)
ruby2.1source(unstable)(unfixed)
ruby2.1sourcejessie2.1.5-2+deb8u8DLA-2007-1
ruby2.3source(unstable)(unfixed)
ruby2.5source(unstable)2.5.7-1

Notes

https://www.ruby-lang.org/en/news/2019/10/01/code-injection-shell-test-cve-2019-16255/
ruby2.5: https://github.com/ruby/ruby/commit/3af01ae1101e0b8815ae5a106be64b0e82a58640

Search for package or bug name: Reporting problems