CVE-2019-20919

NameCVE-2019-20919
DescriptionAn issue was discovered in the DBI module before 1.643 for Perl. The h ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2386-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libdbi-perl (PTS)stretch1.636-1vulnerable
stretch (security)1.636-1+deb9u1fixed
buster1.642-1+deb10u2fixed
bookworm, sid, bullseye1.643-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libdbi-perlsourcestretch1.636-1+deb9u1DLA-2386-1
libdbi-perlsourcebuster1.642-1+deb10u1
libdbi-perlsource(unstable)1.643-1

Notes

https://github.com/perl5-dbi/dbi/commit/eca7d7c8f43d96f6277e86d1000e842eb4cc67ff

Search for package or bug name: Reporting problems