Information on source package libdbi-perl

Available versions

ReleaseVersion
stretch1.636-1
stretch (security)1.636-1+deb9u1
buster1.642-1+deb10u1
bullseye1.643-2
sid1.643-2

Open issues

BugstretchbusterbullseyesidDescription
CVE-2014-10402vulnerable (no DSA, postponed)vulnerable (no DSA, postponed)vulnerablevulnerableAn issue was discovered in the DBI module through 1.643 for Perl. DBD: ...

Resolved issues

BugDescription
CVE-2020-14393A buffer overflow was found in perl-DBI < 1.643 in DBI.xs. A local ...
CVE-2020-14392An untrusted pointer dereference flaw was found in Perl-DBI < 1.643 ...
CVE-2019-20919An issue was discovered in the DBI module before 1.643 for Perl. The h ...
CVE-2014-10401An issue was discovered in the DBI module before 1.632 for Perl. DBD:: ...
CVE-2013-7491An issue was discovered in the DBI module before 1.628 for Perl. Stack ...
CVE-2013-7490An issue was discovered in the DBI module before 1.632 for Perl. Using ...
CVE-2005-0077The DBI library (libdbi-perl) for Perl allows local users to overwrite ...

Security announcements

DSA / DLADescription
DLA-2386-1libdbi-perl - security update
DSA-658-1libdbi-perl - insecure temporary file

Search for package or bug name: Reporting problems