CVE-2019-3824

NameCVE-2019-3824
DescriptionA flaw was found in the way an LDAP search expression could crash the shared LDAP server process of a samba AD DC in samba before version 4.10. An authenticated user, having read permissions on the LDAP server, could use this flaw to cause denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1699-1, DSA-4397-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ldb (PTS)jessie2:1.1.20-0+deb8u1vulnerable
jessie (security)2:1.1.20-0+deb8u2fixed
stretch (security), stretch2:1.1.27-1+deb9u1fixed
buster2:1.5.1+really1.4.6-3fixed
bullseye, sid2:2.0.7-3fixed
samba (PTS)jessie2:4.2.14+dfsg-0+deb8u9vulnerable
jessie (security)2:4.2.14+dfsg-0+deb8u13vulnerable
stretch (security), stretch2:4.5.16+dfsg-1+deb9u2vulnerable
buster2:4.9.5+dfsg-5fixed
buster (security)2:4.9.5+dfsg-5+deb10u1fixed
bullseye, sid2:4.11.0+dfsg-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ldbsource(unstable)2:1.5.1+really1.4.3-2medium
ldbsourcejessie2:1.1.20-0+deb8u2mediumDLA-1699-1
ldbsourcestretch2:1.1.27-1+deb9u1mediumDSA-4397-1
sambasource(unstable)2:4.9.5+dfsg-1unimportant

Notes

https://bugzilla.samba.org/show_bug.cgi?id=13773
Samba uses the System ldb library

Search for package or bug name: Reporting problems