CVE-2019-3856

NameCVE-2019-3856
DescriptionAn integer overflow flaw, which could lead to an out of bounds write, was discovered in libssh2 before 1.8.1 in the way keyboard prompt requests are parsed. A remote attacker who compromises a SSH server may be able to execute code on the client system when a user connects to the server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1730-1, DSA-4431-1
NVD severitymedium (attack range: remote)
Debian Bugs924965

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libssh2 (PTS)jessie1.4.3-4.1+deb8u1vulnerable
jessie (security)1.4.3-4.1+deb8u3fixed
stretch (security), stretch1.7.0-1+deb9u1fixed
bullseye, sid, buster1.8.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libssh2source(unstable)1.8.0-2.1medium924965
libssh2sourcejessie1.4.3-4.1+deb8u2mediumDLA-1730-1
libssh2sourcestretch1.7.0-1+deb9u1mediumDSA-4431-1

Notes

https://www.libssh2.org/CVE-2019-3856.html
Patch: https://libssh2.org/1.8.0-CVE/CVE-2019-3856.patch
https://github.com/libssh2/libssh2/pull/315

Search for package or bug name: Reporting problems