CVE-2019-8322

NameCVE-2019-8322
DescriptionAn issue was discovered in RubyGems 2.6 and later through 3.0.2. The gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1735-1, DLA-1796-1, DLA-2330-1, DSA-4433-1
NVD severitymedium
Debian Bugs925987

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jruby (PTS)stretch1.7.26-1+deb9u1vulnerable
stretch (security)1.7.26-1+deb9u3fixed
bullseye, sid, buster9.1.17.0-3fixed
ruby2.3 (PTS)stretch2.3.3-1+deb9u8fixed
stretch (security)2.3.3-1+deb9u9fixed
ruby2.5 (PTS)buster, buster (security)2.5.5-3+deb10u2fixed
rubygems (PTS)sid3.2.0~rc.1-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jrubysourcejessie1.5.6-9+deb8u1DLA-1796-1
jrubysourcestretch1.7.26-1+deb9u2DLA-2330-1
jrubysource(unstable)9.1.17.0-3925987
ruby2.1sourcejessie2.1.5-2+deb8u7DLA-1735-1
ruby2.1source(unstable)(unfixed)
ruby2.3sourcestretch2.3.3-1+deb9u6DSA-4433-1
ruby2.3source(unstable)(unfixed)
ruby2.5source(unstable)2.5.5-1
rubygemssource(unstable)(unfixed)

Notes

https://www.ruby-lang.org/en/news/2019/03/05/multiple-vulnerabilities-in-rubygems/
https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html
https://github.com/rubygems/rubygems/commit/56c0bbb69e4506bda7ef7f447dfec5db820df20b

Search for package or bug name: Reporting problems