CVE-2019-8331

NameCVE-2019-8331
DescriptionIn Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
twitter-bootstrap (PTS)jessie2.0.2+dfsg-5vulnerable
sid, stretch2.0.2+dfsg-10vulnerable
twitter-bootstrap3 (PTS)jessie3.2.0+dfsg-1vulnerable
jessie (security)3.2.0+dfsg-1+deb7u1vulnerable
stretch3.3.7+dfsg-2+deb9u2fixed
bullseye, sid, buster3.4.1+dfsg-1fixed
twitter-bootstrap4 (PTS)buster4.3.1+dfsg2-1fixed
bullseye, sid4.3.1+dfsg2-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
twitter-bootstrapsource(unstable)(unfixed)medium
twitter-bootstrap3source(unstable)3.4.1+dfsg-1medium
twitter-bootstrap3sourcestretch3.3.7+dfsg-2+deb9u2medium
twitter-bootstrap4source(unstable)4.3.1+dfsg2-1medium

Notes

[jessie] - twitter-bootstrap3 <no-dsa> (Minor issue)
[stretch] - twitter-bootstrap <no-dsa> (Minor issue; XSS in developer-issued input when HTML is enabled)
[jessie] - twitter-bootstrap <no-dsa> (Minor issue; XSS in developer-issued input when HTML is enabled)
https://github.com/twbs/bootstrap/pull/28236

Search for package or bug name: Reporting problems