CVE-2019-9852

NameCVE-2019-9852
DescriptionLibreOffice has a feature where documents can specify that pre-installed macros can be executed on various script events such as mouse-over, document-open etc. Access is intended to be restricted to scripts under the share/Scripts/python, user/Scripts/python sub-directories of the LibreOffice install. Protection was added, to address CVE-2018-16858, to avoid a directory traversal attack where scripts in arbitrary locations on the file system could be executed. However this new protection could be bypassed by a URL encoding attack. In the fixed versions, the parsed url describing the script location is correctly encoded before further processing. This issue affects: Document Foundation LibreOffice versions prior to 6.2.6.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4501-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)jessie1:4.3.3-2+deb8u11vulnerable
jessie (security)1:4.3.3-2+deb8u12vulnerable
stretch1:5.2.7-1+deb9u10fixed
stretch (security)1:5.2.7-1+deb9u11fixed
buster1:6.1.5-3+deb10u3fixed
buster (security)1:6.1.5-3+deb10u4fixed
bullseye, sid1:6.3.2~rc1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:6.3.0-1high
libreofficesourcebuster1:6.1.5-3+deb10u3highDSA-4501-1
libreofficesourcestretch1:5.2.7-1+deb9u10highDSA-4501-1

Notes

https://www.libreoffice.org/about-us/security/advisories/cve-2019-9852/

Search for package or bug name: Reporting problems