CVE-2019-9928

NameCVE-2019-9928
DescriptionGStreamer before 1.16.0 has a heap-based buffer overflow in the RTSP connection parser via a crafted response from a server, potentially allowing remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1769-1, DLA-1770-1, DSA-4437-1
NVD severitymedium
Debian Bugs927978

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-base0.10 (PTS)jessie0.10.36-2vulnerable
jessie (security)0.10.36-2+deb8u1fixed
gst-plugins-base1.0 (PTS)jessie1.4.4-2+deb8u1vulnerable
jessie (security)1.4.4-2+deb8u2fixed
stretch (security), stretch1.10.4-1+deb9u1fixed
buster1.14.4-2fixed
bullseye1.16.1-1fixed
sid1.16.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-base0.10source(unstable)(unfixed)
gst-plugins-base0.10sourcejessie0.10.36-2+deb8u1DLA-1769-1
gst-plugins-base1.0source(unstable)1.14.4-2927978
gst-plugins-base1.0sourceexperimental1.15.90-1
gst-plugins-base1.0sourcejessie1.4.4-2+deb8u2DLA-1770-1
gst-plugins-base1.0sourcestretch1.10.4-1+deb9u1DSA-4437-1

Notes

https://gstreamer.freedesktop.org/security/sa-2019-0001.html
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/merge_requests/157
https://gitlab.freedesktop.org/gstreamer/gst-plugins-base/commit/f672277509705c4034bc92a141eefee4524d15aa (1.15.90)

Search for package or bug name: Reporting problems