CVE-2020-1983

NameCVE-2020-1983
DescriptionA use after free vulnerability in ip_reass() in ip_input.c of libslirp 4.2.0 and prior releases allows crafted packets to cause a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4665-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libslirp (PTS)bullseye, sid4.2.0-2fixed
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u14vulnerable
stretch1:2.8+dfsg-6+deb9u8vulnerable
stretch (security)1:2.8+dfsg-6+deb9u9vulnerable
buster, buster (security)1:3.1+dfsg-8+deb10u5fixed
bullseye, sid1:5.0-5fixed
slirp4netns (PTS)buster0.2.3-1vulnerable
bullseye, sid1.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libslirpsource(unstable)4.2.0-2
qemusource(unstable)1:4.1-2
qemusourcebuster1:3.1+dfsg-8+deb10u5DSA-4665-1
qemu-kvmsource(unstable)(unfixed)
slirp4netnssource(unstable)1.0.1-1

Notes

[buster] - slirp4netns <no-dsa> (Minor issue)
https://gitlab.freedesktop.org/slirp/libslirp/-/commit/9bd6c5913271eabcb7768a58197ed3301fe19f2d
qemu 1:4.1-2 switched to system libslirp, marking that version as fixed
slirp4netns 1.0.1-1 switched to system libslirp, marking that version as fixed.

Search for package or bug name: Reporting problems