CVE-2020-9498

NameCVE-2020-9498
DescriptionApache Guacamole 1.1.0 and older may mishandle pointers involved inprocessing data received via RDP static virtual channels. If a userconnects to a malicious or compromised RDP server, a series ofspecially-crafted PDUs could result in memory corruption, possiblyallowing arbitrary code to be executed with the privileges of therunning guacd process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs964195

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
guacamole-client (PTS)sid, stretch0.9.9+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
guacamole-clientsource(unstable)(unfixed)964195

Notes

https://www.openwall.com/lists/oss-security/2020/07/02/3

Search for package or bug name: Reporting problems