CVE-2021-1056

NameCVE-2021-1056
DescriptionNVIDIA GPU Display Driver for Linux, all versions, contains a vulnerability in the kernel mode layer (nvidia.ko) in which it does not completely honor operating system file system permissions to provide GPU device-level isolation, which may lead to denial of service or information disclosure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs979670, 979671, 979672, 979673, 979674, 979675

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nvidia-graphics-drivers (PTS)stretch/non-free390.138-1vulnerable
buster/non-free418.211.00-1fixed
bullseye/non-free460.91.03-1fixed
bookworm/non-free, sid/non-free470.74-1fixed
nvidia-graphics-drivers-legacy-340xx (PTS)stretch/non-free340.108-3~deb9u1vulnerable
buster/non-free340.108-3~deb10u1vulnerable
sid/non-free340.108-11vulnerable
nvidia-graphics-drivers-legacy-390xx (PTS)buster/non-free390.144-1~deb10u1fixed
bullseye/non-free390.144-1fixed
bookworm/non-free, sid/non-free390.144-2fixed
nvidia-graphics-drivers-tesla-418 (PTS)bullseye/non-free418.211.00-1fixed
bookworm/non-free, sid/non-free418.211.00-2fixed
nvidia-graphics-drivers-tesla-450 (PTS)bullseye/non-free450.142.00-1fixed
bookworm/non-free, sid/non-free450.142.00-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nvidia-graphics-driverssourcebuster418.181.07-1
nvidia-graphics-driverssource(unstable)460.32.03-1979670
nvidia-graphics-drivers-legacy-340xxsource(unstable)(unfixed)979671
nvidia-graphics-drivers-legacy-390xxsourcebuster390.141-2~deb10u1
nvidia-graphics-drivers-legacy-390xxsource(unstable)390.141-1979672
nvidia-graphics-drivers-tesla-418source(unstable)418.181.07-1979673
nvidia-graphics-drivers-tesla-440source(unstable)(unfixed)979674
nvidia-graphics-drivers-tesla-450source(unstable)450.102.04-1979675

Notes

[stretch] - nvidia-graphics-drivers <no-dsa> (Non-free not supported)
[buster] - nvidia-graphics-drivers-legacy-340xx <ignored> (Non-free not supported, no updates provided by Nvidia anymore)
[stretch] - nvidia-graphics-drivers-legacy-340xx <ignored> (Non-free not supported, no updates provided by Nvidia anymore)

Search for package or bug name: Reporting problems