CVE-2021-21708

NameCVE-2021-21708
DescriptionIn PHP versions 7.4.x below 7.4.28, 8.0.x below 8.0.16, and 8.1.x below 8.1.3, when using filter functions with FILTER_VALIDATE_FLOAT filter and min/max limits, if the filter fails, there is a possibility to trigger use of allocated memory after free, which can result it crashes, and potentially in overwrite of other memory chunks and RCE. This issue affects: code that uses FILTER_VALIDATE_FLOAT with min/max limits.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5082-1
Debian Bugs1006672

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.3 (PTS)buster, buster (security)7.3.31-1~deb10u1fixed
php7.4 (PTS)bullseye7.4.30-1+deb11u1fixed
bullseye (security)7.4.33-1+deb11u1fixed
php8.1 (PTS)bookworm, sid8.1.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0source(unstable)(not affected)
php7.3source(unstable)(not affected)
php7.4sourcebullseye7.4.28-1+deb11u1DSA-5082-1
php7.4source(unstable)(unfixed)
php8.1source(unstable)8.1.5-11006672

Notes

- php7.3 <not-affected> (Vulnerable code introduced in 7.4)
- php7.0 <not-affected> (Vulnerable code introduced in 7.4)
Fixed in 8.1.3, 7.4.28
PHP Bug: https://bugs.php.net/81708

Search for package or bug name: Reporting problems