CVE-2021-22116

NameCVE-2021-22116
DescriptionRabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2710-1
Debian Bugs989056

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rabbitmq-server (PTS)stretch3.6.6-1vulnerable
stretch (security)3.6.6-1+deb9u2fixed
buster3.7.8-4vulnerable
bullseye3.8.9-3vulnerable
bookworm, sid3.9.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rabbitmq-serversourcestretch3.6.6-1+deb9u1DLA-2710-1
rabbitmq-serversource(unstable)3.9.4-1989056

Notes

[bullseye] - rabbitmq-server <no-dsa> (Minor issue)
[buster] - rabbitmq-server <no-dsa> (Minor issue)
https://tanzu.vmware.com/security/cve-2021-22116
https://github.com/rabbitmq/rabbitmq-server/pull/2953
Fixed by: https://github.com/rabbitmq/rabbitmq-server/commit/f37a31de55229e6c763215500e376fa16803390b (v3.9.0-beta.1)
Fixed by: https://github.com/rabbitmq/rabbitmq-server/commit/626d5219115d087a2695c0eb243c7ddb7e154563 (v3.8.15-rc.2)

Search for package or bug name: Reporting problems