CVE-2021-32027

NameCVE-2021-32027
DescriptionA flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2662-1, DSA-4915-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-11 (PTS)buster, buster (security)11.12-0+deb10u1fixed
postgresql-13 (PTS)bullseye13.2-1vulnerable
sid13.3-1fixed
postgresql-9.6 (PTS)stretch9.6.17-0+deb9u1vulnerable
stretch (security)9.6.22-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-11sourcebuster11.12-0+deb10u1DSA-4915-1
postgresql-11source(unstable)(unfixed)
postgresql-13source(unstable)13.3-1
postgresql-9.6sourcestretch9.6.22-0+deb9u1DLA-2662-1
postgresql-9.6source(unstable)(unfixed)

Notes

https://www.postgresql.org/about/news/postgresql-133-127-1112-1017-and-9622-released-2210/
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=467395bfdf33f1ccf67ca388ffdcc927271544cb (REL_13_3)

Search for package or bug name: Reporting problems