CVE-2021-41182

NameCVE-2021-41182
DescriptionjQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. A workaround is to not accept the value of the `altField` option from untrusted sources.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2889-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jqueryui (PTS)buster1.12.1+dfsg-5vulnerable
bullseye1.12.1+dfsg-8+deb11u1fixed
bookworm, sid1.13.2+dfsg-1fixed
otrs2 (PTS)buster/non-free6.0.16-2vulnerable
bullseye/non-free6.0.32-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7sourcestretch7.52-2+deb9u17DLA-2889-1
drupal7source(unstable)(unfixed)
jqueryuisourcebullseye1.12.1+dfsg-8+deb11u1
jqueryuisource(unstable)1.13.0+dfsg-1
otrs2source(unstable)6.3.1-1

Notes

[buster] - jqueryui <no-dsa> (Minor issue)
[stretch] - jqueryui <no-dsa> (Minor issue)
[bullseye] - otrs2 <no-dsa> (Non-free not supported)
[buster] - otrs2 <no-dsa> (Non-free not supported)
[stretch] - otrs2 <no-dsa> (Non-free not supported)
https://github.com/jquery/jquery-ui/security/advisories/GHSA-9gj3-hwp5-pmwc
https://github.com/jquery/jquery-ui/commit/32850869d308d5e7c9bf3e3b4d483ea886d373ce
https://www.drupal.org/sa-core-2022-002
https://www.znuny.org/en/advisories/zsa-2022-01

Search for package or bug name: Reporting problems