CVE-2021-46142

NameCVE-2021-46142
DescriptionAn issue was discovered in uriparser before 0.9.6. It performs invalid free operations in uriNormalizeSyntax.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2883-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
uriparser (PTS)stretch0.8.4-1+deb9u1vulnerable
stretch (security)0.8.4-1+deb9u3fixed
buster0.9.1-1vulnerable
bullseye0.9.4+dfsg-1vulnerable
bookworm, sid0.9.6+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
uriparsersourcestretch0.8.4-1+deb9u3DLA-2883-1
uriparsersource(unstable)0.9.6+dfsg-1

Notes

https://github.com/uriparser/uriparser/issues/122
https://github.com/uriparser/uriparser/commit/c0483990e6b5b454f7c8752b36760cfcb0d093f5 (uriparser-0.9.6)
https://github.com/uriparser/uriparser/pull/124

Search for package or bug name: Reporting problems