DescriptionThe LSP (Language Server Protocol) plugin in KDE Kate before 21.12.2 and KTextEditor before 5.91.0 tries to execute the associated LSP server binary when opening a file of a given type. If this binary is absent from the PATH, it will try running the LSP server binary in the directory of the file that was just opened (due to a misunderstanding of the QProcess API, that was never intended). This can be an untrusted directory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1010180

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kate (PTS)buster4:18.08.0-1vulnerable
bookworm, sid4:22.04.3-1fixed
ktexteditor (PTS)buster5.54.0-1vulnerable
bookworm, sid5.98.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - kate <no-dsa> (Minor issue)
[buster] - kate <no-dsa> (Minor issue)
[stretch] - kate <no-dsa> (Minor issue)
[bullseye] - ktexteditor <no-dsa> (Minor issue)
[buster] - ktexteditor <no-dsa> (Minor issue)
[stretch] - ktexteditor <no-dsa> (Minor issue)
KTextEditor: Fixed by:
KTextEditor: Fixed by:
Kate: prerequisites:
Fixed by:
Fixed by:

Search for package or bug name: Reporting problems