CVE-2022-24761

NameCVE-2022-24761
DescriptionWaitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: The use of Python's `int()` to parse strings into integers, leading to `+10` to be parsed as `10`, or `0x01` to be parsed as `1`, where as the standard specifies that the string should contain only digits or hex digits; and Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters. This vulnerability has been patched in Waitress 2.1.1. A workaround is available. When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy servers may not have this functionality though and users are encouraged to upgrade to the latest version of waitress instead.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3000-1, DSA-5138-1
Debian Bugs1008013

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
waitress (PTS)stretch1.0.1-1vulnerable
stretch (security)1.0.1-1+deb9u1fixed
buster1.2.0~b2-2vulnerable
buster (security)1.2.0~b2-2+deb10u1fixed
bullseye1.4.4-1.1vulnerable
bullseye (security)1.4.4-1.1+deb11u1fixed
bookworm, sid2.1.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
waitresssourcestretch1.0.1-1+deb9u1DLA-3000-1
waitresssourcebuster1.2.0~b2-2+deb10u1DSA-5138-1
waitresssourcebullseye1.4.4-1.1+deb11u1DSA-5138-1
waitresssource(unstable)2.1.1-11008013

Notes

https://github.com/Pylons/waitress/security/advisories/GHSA-4f7p-27jc-3c36
https://github.com/Pylons/waitress/commit/9e0b8c801e4d505c2ffc91b891af4ba48af715e0 (v2.1.1)

Search for package or bug name: Reporting problems