CVE-2022-26307

NameCVE-2022-26307
DescriptionLibreOffice supports the storage of passwords for web connections in the user’s configuration database. The stored passwords are encrypted with a single master key provided by the user. A flaw in LibreOffice existed where master key was poorly encoded resulting in weakening its entropy from 128 to 43 bits making the stored passwords vulerable to a brute force attack if an attacker has access to the users stored config. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)buster1:6.1.5-3+deb10u7vulnerable
buster (security)1:6.1.5-3+deb10u4vulnerable
bullseye (security), bullseye1:7.0.4-4+deb11u1vulnerable
bookworm, sid1:7.4.0~rc3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesource(unstable)1:7.3.3~rc1-2

Notes

[bullseye] - libreoffice <no-dsa> (Minor issue)
[buster] - libreoffice <no-dsa> (Minor issue)
https://www.libreoffice.org/about-us/security/advisories/cve-2022-26307

Search for package or bug name: Reporting problems