CVE-2022-27337

NameCVE-2022-27337
DescriptionA logic error in the Hints::Hints function of Poppler v22.03.0 allows attackers to cause a Denial of Service (DoS) via a crafted PDF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3120-1, DSA-5224-1
Debian Bugs1010695

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)buster0.71.0-5vulnerable
buster (security)0.71.0-5+deb10u1fixed
bullseye20.09.0-3.1vulnerable
bullseye (security)20.09.0-3.1+deb11u1fixed
bookworm, sid22.08.0-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersourcebuster0.71.0-5+deb10u1DLA-3120-1
popplersourcebullseye20.09.0-3.1+deb11u1DSA-5224-1
popplersource(unstable)22.08.0-21010695

Notes

[stretch] - poppler <postponed> (Minor issue)
https://gitlab.freedesktop.org/poppler/poppler/-/issues/1230
https://gitlab.freedesktop.org/poppler/poppler/-/commit/81044c64b9ed9a10ae82a28bac753060bdfdac74 (poppler-22.04.0)

Search for package or bug name: Reporting problems