CVE-2022-28805

NameCVE-2022-28805
Descriptionsinglevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1010265

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lua5.1 (PTS)buster, bullseye5.1.5-8.1fixed
bookworm, sid5.1.5-9fixed
lua5.2 (PTS)buster, bullseye5.2.4-1.1fixed
bookworm, sid5.2.4-2fixed
lua5.3 (PTS)buster, bullseye5.3.3-1.1fixed
bookworm, sid5.3.6-1fixed
lua5.4 (PTS)bullseye5.4.2-2vulnerable
bookworm, sid5.4.4-3fixed
lua50 (PTS)buster5.0.3-8fixed
bullseye5.0.3-8.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lua5.1source(unstable)(not affected)
lua5.2source(unstable)(not affected)
lua5.3source(unstable)(not affected)
lua5.4source(unstable)5.4.4-21010265
lua50source(unstable)(not affected)

Notes

[bullseye] - lua5.4 <no-dsa> (Minor issue)
- lua5.3 <not-affected> (Specific to 5.4, see #1010265)
- lua5.2 <not-affected> (Specific to 5.4, see #1010265)
- lua5.1 <not-affected> (Specific to 5.4, see #1010265)
- lua50 <not-affected> (Specific to 5.4, see #1010265)
https://github.com/lua/lua/commit/1f3c6f4534c6411313361697d98d1145a1f030fa
http://lua-users.org/lists/lua-l/2022-02/msg00001.html
http://lua-users.org/lists/lua-l/2022-02/msg00070.html

Search for package or bug name: Reporting problems