Information on source package lua5.2

Available versions

ReleaseVersion
buster5.2.4-1.1
bullseye5.2.4-1.1
bookworm5.2.4-2
sid5.2.4-2

Open issues

BugbusterbullseyebookwormsidDescription
CVE-2021-43519vulnerable (no DSA)vulnerable (no DSA)vulnerablevulnerableStack overflow in lua_resume of ldo.c in Lua Interpreter 5.1.0~5.4.4 a ...

Resolved issues

BugDescription
CVE-2022-33099An issue in the component luaG_runerror of Lua v5.4.4 and below leads ...
CVE-2022-28805singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) ...
CVE-2021-44647Lua v5.4.3 and above are affected by SEGV by type confusion in funcnam ...
CVE-2020-15945Lua through 5.4.0 has a segmentation fault in changedline in ldebug.c ...
CVE-2019-6706Lua 5.3.5 has a use-after-free in lua_upvaluejoin in lapi.c. For examp ...
CVE-2014-5461Buffer overflow in the vararg functions in ldo.c in Lua 5.1 through 5. ...

Security announcements

DSA / DLADescription
DSA-3016-1lua5.2 - security update

Search for package or bug name: Reporting problems