CVE-2022-30122

NameCVE-2022-30122
DescriptionA possible denial of service vulnerability exists in Rack <2.0.9.1, <2.1.4.1 and <2.2.3.1 in the multipart parsing component of Rack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3095-1, DSA-5530-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-rack (PTS)buster2.0.6-3vulnerable
buster (security)2.0.6-3+deb10u4fixed
bullseye2.1.4-3+deb11u1fixed
bullseye (security)2.1.4-3+deb11u2fixed
bookworm2.2.6.4-1fixed
bookworm (security)2.2.6.4-1+deb12u1fixed
sid, trixie2.2.7-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-racksourcebuster2.0.6-3+deb10u1DLA-3095-1
ruby-racksourcebullseye2.1.4-3+deb11u1DSA-5530-1
ruby-racksource(unstable)2.2.4-1

Notes

https://groups.google.com/g/ruby-security-ann/c/L2Axto442qk
https://github.com/advisories/GHSA-hxqx-xwvh-44m2
https://github.com/rack/rack/commit/d286516cbd58fbb2ad6944ce9040e9ba96d9371a (3.0.0.beta1)
https://github.com/rack/rack/commit/a872bcce127a6f4a0f16af8f28b686955ba32814 (2.2.3.1)
https://github.com/rack/rack/commit/41be3d7f3fd73ccf246ad97c3831d02f99d2ce84 (2.1.4.1)

Search for package or bug name: Reporting problems