CVE-2022-30688

NameCVE-2022-30688
Descriptionneedrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-3013-1, DSA-5137-1
Debian Bugs1011154

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
needrestart (PTS)stretch2.11-3+deb9u1vulnerable
stretch (security)2.11-3+deb9u2fixed
buster3.4-5vulnerable
buster (security)3.4-5+deb10u1fixed
bullseye3.5-4vulnerable
bullseye (security)3.5-4+deb11u1fixed
bookworm, sid3.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
needrestartsourcestretch2.11-3+deb9u2DLA-3013-1
needrestartsourcebuster3.4-5+deb10u1DSA-5137-1
needrestartsourcebullseye3.5-4+deb11u1DSA-5137-1
needrestartsource(unstable)3.6-11011154

Notes

https://github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30 (v3.6)
https://www.openwall.com/lists/oss-security/2022/05/17/9

Search for package or bug name: Reporting problems