DescriptionIn PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when using Postgres database extension, supplying invalid parameters to the parametrized query may lead to PHP attempting to free memory using uninitialized data as pointers. This could lead to RCE vulnerability or denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.3 (PTS)buster, buster (security)7.3.31-1~deb10u1vulnerable
php7.4 (PTS)bullseye (security), bullseye7.4.28-1+deb11u1vulnerable
php8.1 (PTS)bookworm, sid8.1.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - php7.4 <postponed> (Minor issue, fix along with next security release)
[buster] - php7.3 <postponed> (Minor issue, fix along with next security release)
[stretch] - php7.0 <postponed> (Minor issue; can be fixed in next update)
Fixed in 7.4.30, 8.0.20, 8.1.7
PHP Bug:

Search for package or bug name: Reporting problems