CVE-2022-31628

NameCVE-2022-31628
DescriptionIn PHP versions before 7.4.31, 8.0.24 and 8.1.11, the phar uncompressor code would recursively uncompress "quines" gzip files, resulting in an infinite loop.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5277-1
Debian Bugs1021138

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.3 (PTS)buster, buster (security)7.3.31-1~deb10u1vulnerable
php7.4 (PTS)bullseye7.4.30-1+deb11u1vulnerable
bullseye (security)7.4.33-1+deb11u1fixed
php8.1 (PTS)bookworm, sid8.1.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.3source(unstable)(unfixed)
php7.4sourcebullseye7.4.33-1+deb11u1DSA-5277-1
php7.4source(unstable)(unfixed)
php8.1source(unstable)8.1.12-11021138

Notes

Fixed in 8.1.11, 7.4.32
PHP Bug: https://bugs.php.net/bug.php?id=81726
https://github.com/php/php-src/commit/404e8bdb68350931176a5bdc86fc417b34fb583d
https://github.com/php/php-src/commit/432bf196d59bcb661fcf9cb7029cea9b43f490af

Search for package or bug name: Reporting problems