CVE-2022-32923

NameCVE-2022-32923
DescriptionA correctness issue in the JIT was addressed with improved checks. This issue is fixed in tvOS 16.1, iOS 15.7.1 and iPadOS 15.7.1, macOS Ventura 13, watchOS 9.1, Safari 16.1, iOS 16.1 and iPadOS 16. Processing maliciously crafted web content may disclose internal states of the app.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3124-1, DSA-5240-1, DSA-5241-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1vulnerable
buster (security)2.38.6-0+deb10u1fixed
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.42.5-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.42.5-1~deb12u1fixed
sid, trixie2.42.5-1fixed
wpewebkit (PTS)bullseye (security), bullseye2.38.6-1~deb11u1fixed
bookworm2.38.6-1fixed
trixie2.42.5-1fixed
sid2.42.5-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.38.0-1~deb10u1DLA-3124-1
webkit2gtksourcebullseye2.38.0-1~deb11u1DSA-5240-1
webkit2gtksource(unstable)2.38.0-1
wpewebkitsourcebullseye2.38.0-1~deb11u1DSA-5241-1
wpewebkitsource(unstable)2.38.0-1

Notes

https://webkitgtk.org/security/WSA-2022-0010.html

Search for package or bug name: Reporting problems