CVE-2022-33099

NameCVE-2022-33099
DescriptionAn issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1014935

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lua5.1 (PTS)buster, bullseye5.1.5-8.1fixed
bookworm, sid5.1.5-9fixed
lua5.2 (PTS)buster, bullseye5.2.4-1.1fixed
bookworm, sid5.2.4-2fixed
lua5.3 (PTS)buster, bullseye5.3.3-1.1fixed
bookworm, sid5.3.6-1fixed
lua5.4 (PTS)bullseye5.4.2-2vulnerable
bookworm, sid5.4.4-3fixed
lua50 (PTS)buster5.0.3-8fixed
bullseye5.0.3-8.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lua5.1source(unstable)(not affected)
lua5.2source(unstable)(not affected)
lua5.3source(unstable)(not affected)
lua5.4source(unstable)5.4.4-31014935
lua50source(unstable)(not affected)

Notes

[bullseye] - lua5.4 <no-dsa> (Minor issue)
- lua5.3 <not-affected> (Specific to 5.4)
- lua5.2 <not-affected> (Specific to 5.4)
- lua5.1 <not-affected> (Specific to 5.4)
- lua50 <not-affected> (Specific to 5.4)
https://github.com/lua/lua/commit/42d40581dd919fb134c07027ca1ce0844c670daf
https://lua-users.org/lists/lua-l/2022-05/msg00035.html
https://lua-users.org/lists/lua-l/2022-05/msg00042.html
https://lua-users.org/lists/lua-l/2022-05/msg00073.html

Search for package or bug name: Reporting problems