CVE-2022-45062

NameCVE-2022-45062
DescriptionIn Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1023732

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xfce4-settings (PTS)buster4.12.4-1fixed
bullseye4.16.0-1vulnerable
bookworm, sid4.16.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xfce4-settingssourcebuster(not affected)
xfce4-settingssource(unstable)4.16.4-11023732

Notes

[buster] - xfce4-settings <not-affected> (The vulnerable code was introduced later)
https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/390
https://gitlab.xfce.org/xfce/xfce4-settings/-/commit/f34a92a84f96268ad24a7a13fd5edc9f1d526110 (xfce4-settings-4.17.1)
https://gitlab.xfce.org/xfce/xfce4-settings/-/commit/55e3c5fb667e96ad1412cf249879262b369d28d7 (xfce4-settings-4.16.4)
Regression from the CVE fix with filenames with spaces:
https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/403
https://gitlab.xfce.org/xfce/xfce4-settings/-/merge_requests/85

Search for package or bug name: Reporting problems