DescriptionIn Xfce xfce4-settings before 4.16.4 and 4.17.x before 4.17.1, there is an argument injection vulnerability in xfce4-mime-helper.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1023732

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xfce4-settings (PTS)buster4.12.4-1fixed
bookworm, sid4.16.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xfce4-settingssourcebuster(not affected)


[buster] - xfce4-settings <not-affected> (The vulnerable code was introduced later) (xfce4-settings-4.17.1) (xfce4-settings-4.16.4)
Regression from the CVE fix with filenames with spaces:

Search for package or bug name: Reporting problems