CVE-2023-0950

NameCVE-2023-0950
DescriptionImproper Validation of Array Index vulnerability in the spreadsheet component of The Document Foundation LibreOffice allows an attacker to craft a spreadsheet document that will cause an array index underflow when loaded. In the affected versions of LibreOffice certain malformed spreadsheet formulas, such as AGGREGATE, could be created with less parameters passed to the formula interpreter than it expected, leading to an array index underflow, in which case there is a risk that arbitrary code could be executed. This issue affects: The Document Foundation LibreOffice 7.4 versions prior to 7.4.6; 7.5 versions prior to 7.5.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3526-1, DSA-5415-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libreoffice (PTS)buster1:6.1.5-3+deb10u7vulnerable
buster (security)1:6.1.5-3+deb10u12fixed
bullseye1:7.0.4-4+deb11u8fixed
bullseye (security)1:7.0.4-4+deb11u9fixed
bookworm4:7.4.7-1+deb12u1fixed
bookworm (security)4:7.4.7-1+deb12u2fixed
trixie4:24.2.3-2fixed
sid4:24.2.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libreofficesourcebuster1:6.1.5-3+deb10u10DLA-3526-1
libreofficesourcebullseye1:7.0.4-4+deb11u7DSA-5415-1
libreofficesource(unstable)4:7.4.5-3

Notes

https://www.libreoffice.org/about-us/security/advisories/cve-2023-0950/

Search for package or bug name: Reporting problems